Not signed in (Sign In)
    •  
      CommentAuthormichelle
    • CommentTimeMay 16th 2010
     
    Hi there,
    In Clean Home Pro I'm wondering if there is a way that I can use the images that are associated with featured articles or generic images of my choice rather than a gravatar if I use the featured posts in 3 categories option on the home page. I'm trying to use it as much like a magazine theme as possible. Also, wondering if some posts can have images in this option while others don't.

    thanks!
    michelle
    •  
      CommentAuthorBryan
    • CommentTimeMay 18th 2010
     
    I would recommend some of the post thumbnail plugins floating around, as there are quite a few. It might require you editing home.php to place the important bits of code, but if you can find a promising plugin, I'd be happy to help!
    •  
      CommentAuthormichelle
    • CommentTimeJun 5th 2010
     
    ok, thanks, I'll look into it. I'm assuming the above would allow me to use whichever thumbnail (of my choosing) goes with each post?
    thanks!
    •  
      CommentAuthorBryan
    • CommentTimeJun 7th 2010
     
    Some offer that functionality! You might have to try a few to get it working the way you like.
    •  
      CommentAuthorMartin
    • CommentTimeAug 6th 2010
     
    is there a way, to have just replace the gravatar image and have it display one of your own images from a local folder instead? I don't really use gravatars..
    •  
      CommentAuthorMartin
    • CommentTimeAug 6th 2010
     
    Well, not on my blog anyway...lol
    •  
      CommentAuthormichelle
    • CommentTimeAug 13th 2010
     
    Hi there
    I've installed all sorts of thumbnail plugins (in addition to WP 3.01 which I think has native abilities like this i think?), but still can't get them to work to use the post image or selected images on the homepage "avatar" spot in the featured posts view. For example, I'm trying "Generate Thumbnails" and "Auto Post Thumbnails" plugin but when I try to activate it and use through the tools menu I get a message that it isn't supported by the theme, etc.
    http://wordpress.shaldybina.com/plugins/generate-post-thumbnails/
    I also have "Get the image" plugin.
    What can I add or change, and where, to get this or something like it to work.
    My site is tincanstring.com.
    Thanks!!
    Michelle
    •  
      CommentAuthormichelle
    • CommentTimeAug 13th 2010
     
    http://www.sanisoft.com/blog/2010/04/19/wordpress-plugin-automatic-post-thumbnail/
    •  
      CommentAuthormichelle
    • CommentTimeAug 14th 2010
     
    Addendum, I'm just going to try to use the Featured Image Thumbnail in wp to enable thumbnails as described here:
    http://nenuno.co.uk/creative/wordpress/adding-post-thumbnails-to-wordpress-3-0/
    , but in Clean Home Pro I'm not getting the "featured image" option on the post editor; how do I update the code to be able to enable this?
    Also, not sure whether to update index.php or home.php (i assume the former) or both. thx!
    •  
      CommentAuthormichelle
    • CommentTimeAug 14th 2010
     
    Ok managed to enable the feature in the post editor, but still nothing on the avatar spot.
    •  
      CommentAuthormichelle
    • CommentTimeAug 17th 2010 edited
     
    Any clues? I've got thumbnails enabled, how do I get them in the Avatar spots?
    I'm putting this code
    <?php the_post_thumbnail(array(130,98), array('class' => 'alignleft post_thumbnail'));?>

    on the index and home templates (I'd use a square one for the home template, I'd guess), but I don't know where to put them on home.php and how to replace the avatars with them. Is there somewhere in the stylesheet I can just say featuredavatar=post_thumbnail or something?
    •  
      CommentAuthorBryan
    • CommentTimeAug 26th 2010
     
    Replace the <?php echo get_avatar( get_the_author_email(), (int)get_option(chp_featured_avatar_size) ); ?> code with the img HTML (or php that generates the HTML) for the thumbnail.
    •  
      CommentAuthormichelle
    • CommentTimeSep 12th 2010
     
    Thanks much! just what I was looking for, will try it out on my test blog, if I haven't hacked it up beyond recognition...
    •  
      CommentAuthormichelle
    • CommentTimeSep 23rd 2010
     
    I tried the above suggestion and it worked, thanks! I ended up sticking with my original work-around which looks pretty much the same (I thought the avatar code might line up the boxes a bit better?). Not using that view at the moment but will be.

    One thing to note: When I made the avatar substitution in the "home" page file, it changed the image position in my "main index" page file (the header bar for each post is slightly different in each)--for some reason I thought those were completely separate entitities. All's good with the thumbnails though.