Not signed in (Sign In)
    •  
      CommentAuthorjmisner
    • CommentTimeApr 11th 2009
     
    Hello,

    Recently purchased Clean Home Pro, excellent theme! Likely a stupid question here, but I just can't seem to find the FeedBurner ID# in the form of a 6-7 number code. In the code snippet in FeedBurner post activation, there is no code as you describe whatsoever. Specifically, I'm looking in Publicize > Email Subscriptions > Subscription Management. I can easily be just overlooking this, but could someone kindly post where to find this ID#?

    Thanks!
    •  
      CommentAuthorjmisner
    • CommentTimeApr 11th 2009 edited
     
    Just wanted to follow up on my previous post.

    After a short bit of researching this, it seems that since the Google acquisition of FeedBurner, the ID # is now considered legacy and the ID name is now prominent. I could be wrong, but I've gathered this from many posts I've pulled up from various forums off Google.

    Also, wanted to note a bit of a bug report on the same subject. Seems like FeedBurner is also assigning feed addresses other than "http://feeds.feedburner.com/feedname". Just for example, the feed I just recently created on FeedBurner assigned me the domain "http://feeds2.feedburner.com/feedname"...notice the number 2 in the subdomain. On a related note, I've created a FeedBurner MyBrand address so that I can use my own domain name with my feeds, and it seems that the Clean Home theme doesn't currently support this.

    Perhaps the "RSS Feedburner Name" should just ask for the complete URL instead of just the FeedBurner ID? For now I think I'm going to just edit the header.php file to force everything to work. Thank you!
    •  
      CommentAuthorBryan
    • CommentTimeApr 11th 2009 edited
     
    Jmisner, you are absolutely correct. Since Google acquired Feedburner, they've mucked things up real good for people who used the legacy way to do things. Here is the corrected code, simply input your entire URL in for this to work:


    <form class="subscribe" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('<?php echo get_option(chp_feedburner_id_num);?>', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter your email address:</p><p><input type="text" style="width:140px" name="email"/></p><input type="hidden" value="<?php echo get_option(chp_feedburner_id_num);?>" name="url"/><input type="hidden" value="<?php bloginfo('name'); ?>" name="title"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Subscribe" /><p>Delivered by <a href="http://www.feedburner.com" target="_blank">FeedBurner</a></p></form>


    The header is the same stuff:


    <link rel="alternate" type="application/rss+xml" title="Feedburner" href="<?php echo $chp_feedburner_id_name;?>"/>


    Now just input your entire URLs in the appropriate field.

    I am working on an update for the file, I'll get that available for download as soon as everything is sorted out.

    Let me know!
    •  
      CommentAuthorjmisner
    • CommentTimeApr 11th 2009
     
    Thank you for a weekend reply. The new header code worked great.

    Had a problem with the sidebar code though. When trying to send an email subscription, FeedBurner was giving me an error that "The feed does not have subscriptions by email enabled" when email subscriptions are activated, so I thought there may have been a bug in the new code. I did find that FeedBurner may be expecting this in the initial form tag:

    onsubmit="window.open('http://feedburner.google.com/fb/a/mailverify?uri=<?php echo get_option(chp_feedburner_id_num);?>'

    ...so I edited your revised code with that. That is the format that was used in the code snippet on FeedBurner's site, plus get_option(). However, FeedBurner is still throwing the same error. May be an error or delay at FeedBurner's end or a bug somewhere, I don't know.

    I'm not too worried about it though, not pressed to get e-mail subscriptions up right away. I'll grab your updated download in the future and see what happens then. Thanks again!
    •  
      CommentAuthorBryan
    • CommentTimeApr 12th 2009
     
    That's interesting, I'll look into it.
    •  
      CommentAuthorthreio
    • CommentTimeApr 25th 2009 edited
     
    not to but in, but is this the same code in Megatheme Pro Magazine Theme?

    If yes, I had the same problem initially, when I entered the code in the theme's options page.

    I solved this problem by directly adding my Feedburner code to the sidebar.php and it worked. (the feedburner code is still present on the theme options page.
    •  
      CommentAuthorBryan
    • CommentTimeApr 26th 2009 edited
     
    I think you're right threio. The same problem is hitting a lot of users, this is primarily because Google changed it up and partly because I wasn't forward thinking enough.

    There should be some newer versions out soon.
    •  
      CommentAuthorCalbeart
    • CommentTimeMay 18th 2009
     
    Jmisner,

    I was having the same problem and i fixed it by altering the theme template code in Sidebar.php to the following:

    <form class="subscribe" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('http://feedburner.google.com/fb/a/mailverify?uri=feedname', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter your email address:</p><p><input type="text" style="width:140px" name="email"/></p><input type="hidden" value="feedname" name="uri"/><input type="hidden" value="<?php bloginfo('name'); ?>" name="title"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Subscribe" /><p>Delivered by <a href="http://www.feedburner.com" target="_blank">FeedBurner</a></p></form>

    Just replace the "feedname" with yours from feedburner and enter the feedname as your Feedburner ID# in the theme options and you should be good to go.

    Hope this helps,
    Trevor
    •  
      CommentAuthorDecio
    • CommentTimeJan 5th 2010
     
    I just bought the excellent Clean Home Pro theme, and I run into the same problem. I found this thread here and I wonder if you had the time to update this theme files or should I just go and update them myself?

    I'm just not sure where should I should substitute this lines of code.

    Decio.
    •  
      CommentAuthorDecio
    • CommentTimeJan 5th 2010
     
    Don't bother, I decided to use the code given by feedburner.

    Tks.
    •  
      CommentAuthorBryan
    • CommentTimeJan 9th 2010 edited
     
    Sorry about the confusion! It arises as Google changed the Feedburner code after they acquired it.

    Calbeart had a solution as well. If someone finds this doesn't work, let me know.